New Donkey.. No Go

Greetings All,

I just got my Donkey Car set up (Fabo kit with raspberry pi, logitec 710 controller)

I am having problems when trying to drive in joystick mode. Steering on channel 1 works fine, but no acceleration control on channel 0.

I was able to drive around just fine but when I opted to increase the speed value, I lost control of acceleration. I’ve re-loaded a new config file and still no luck.

I should note that I’ve tried switching the channel 0(esc) and channel 1(steering servo) lines on the pwm board. When doing so, I am able to control the acceleration with channel 1, but still nothing from channel 0.

Ok, well I found my problem…

Posting results here in case someone else has the same issue in the future.

Because I was able to control acceleration from channel 1 (normally the steering channel), everything on the car was doing what it was supposed to do. The issue was with the Logitec F710 controller. Somehow it would not transmit a signal from the right joystick (channel 0). Did a software download from the Logitec support website and the controller functions as it should now.

Cheers!