I cant start the " python manage.py drive"

Hello everyone ,I finish the Steering Calibration and Throttle Calibration,but i cant start manage.py to “Fine tuning your calibration”, idle told me no module named donkeycar and


so how to fix it ,i have no idea :thinking:

image

image

I assume you edited your myconfig.py file in your mycar directory. If so, it appears you added a tab before that STEERING_CHANNEL line. Please delete it.

BTW, why are you running Idle? You should just be starting Donkey from the command line as you did in your screenshot. As you can see, if found the donkeycar module fine when you did that.

@cuilao2011 the problem is spelled out for you right there on your screen… IndentationError

https://www.google.com/search?q=python+indentation+error
Practice your Google-Fu. :slight_smile:

Unlike many other programming languages, Python is particular about what’s called “white space” so spaces and tabs in the code matter. Since you edited myconfig.py for calibration, you just not have used correct white space when you copied and pasted(or typed ) the the configuration elements you wanted to customize.

I haven’t used python language classes for too long :sleeping:Somewhat rusty about the code format, Wèntí jiějuéle, chénggōng yùnxíng donkeycar
The problem is solved, donkeycar runs successfully :yum: :yum:
thanks

thanks,im fixed it:smiling_face_with_three_hearts: